Similar to Rondo - Cant convert avi to dvd


New member
I have similar issues to Rondo.
I have been using Chickenman's excellent guide to DVD2SVCD (v1.2.3B1) plus CCE v2.5, lately D2SRoba 3.8 and also TMPGEnc Author to create the DVDs.
This is a great combination although a little slow on a P4 2.8Ghz.

I have also tried Winavi, DVD2AVI (the authoring is too hard, its also slow, its reqts to name the file are weird), Cucusoft and the Film Machine. I have just downloaded DIKO but haven't tried it.

I have converted 100 plus successful files with few failures over 18 months.

Recently there seems to be several TV series and some movies coming out with avi (xvid) files that just crash in all the programs above.
I have started checking them with Virtual Dub ie Video preview. Strangely they all crash VD with a divide by integer zero in frame 0 message.
The short form message is
"integer division by zero occurred in module 'xvid'
while decompressing video frame 1 (VideoSource.cpp:1718)
while using input buffer at 012b0000-012b1093 (VideoSource.cpp:1717)
while using output buffer at 018a0000-01976803 (VideoSource.cpp:1716)
while running thread "Processing" (thread.cpp:150)."

I checked one of the files with DivFix and it reported no errors. I can play all the files in WMP, DIVX Player and as files on Xbox and on file reading (DIVX) DVD player.

Yes I have the lastest XVID v1.1 codec installed. Both avicodec and Gspot report no issues and Gspot can preview the files. All the problem ones are XVID. Some of the the files are extremely popular so I assume others must have problems.

Someone else reported that he can open one file in Virtual Dub. My version is the latest and it works on most files OK. Maybe I have some setup wrongly but its hard to understand with so many successful conversions.

Any ideas you can offer would be greatly appreciated as I am very frustrated.


New member

I found a thread on Doom9 Forum DVD and SVCD,
Thread DVD2SVCD and generic (S)VCD encoding and authoring,
DVD2SVCD Problems specific to AVI input by Nick DVD2SVCD Forum, 21Sep2005, ref

If you have problems with audio sync, or audio/video cut out unexpectedly, try this.
Download VDubMod

Unpack VDubMod and run it.
Load your avi file - if you get an error asking about rewriting the header, CLICK NO!!!
* Go to the "VIDEO" menu and select "DIRECT STREAM COPY"
* Go to the "FILE" menu and select "SAVE AS AVI". Select a new filename.
* When VDubMod has saved the AVI, close it and use the new AVI file in DVD2SVCD

If your AVI has mono audio, it will not convert properly in DVD2SVCD - the output will be double speed and sound very high pitched. If this is the case (VDubMod File menu > File information will tell you), then go into Streams menu > Streams list and right-click on the audio stream. Select "Full Processing mode" from the menu that appears. Now right click again and choose Conversion. In the window that opens, select Stereo under the "Channels" heading and click OK. Save the AVI as instructed above and it should now work.

My Additions to this are:

I have used this and can convert the resultant file.

The above saves the avi with exactly same bytes. Once saved you can open the new avi in full processing mode in Virtual Dub.

Similarly with Virtual Dub you get a message about rewriting the header. Open file and Click OK or tick crossed box.
* Go to the "VIDEO" menu and select "DIRECT STREAM COPY"
* Go to the "FILE" menu and select "SAVE AS AVI". Select a new filename.
* When VDubMod has saved the AVI, close it and use the new AVI file in DVD2SVCD
* Go to the "FILE" menu. Select “Preview Input”. Should play the video.

Saves 350Mytes avi files with about 1Mbyte less.

These new file created with either VDM or VD can then be converted with ones favourite program.
Thats a standard method of "fixing" many avi's as it writes out a complete new header. But I thought you said they crash in VirtualDUB. So they dont crash in VirtualDUBMOD then ? Then I assume the audio in the avi's is AC3 ?


New member
i have had this happen a few times for me and have heard loads of different ways to do it.
if you go in to control panel/sounds and audio devices/hardware yo can then see all the audio and video codecs installed on your machine. Clicking on each one should give you a working notification except the problem codec.
This seemed to work for some people.
It didnt for me. I had to delete the file in windows/system32 everytime I have had this problem. Seems to be that it will never be updated when already in existence. Then install your latest codec pack.
May not work for you but it is working for me.
The only problem I have now is that DVD santa gives me "unsupported audio stream" - cant be right with everything i suppose