Midi Audio Problems

#1
Hi everyone,

I'm having a problem playing MIDI files on my computer. It plays but no sound comes out. I've tried updating drivers, downloading other audio programs, and every other thing I could think of but nothing helps.

In control panelAudio Properties there is a drop down box where you can select Default MIDI playback device. When I select my soundcard (the only available selection there) and click apply, it bounces back to an empty selection. Please help with this [problem. Thank you so much
 
#2
Which windows version? - the default for Windows XP is the Microsoft GS software wavetable.

If you can find them all, the following would be useful...
1. Windows version
2. Soundcard make, model or chipset
3. DirectX version - actually, going through DXdiag is a good idea, it might be where the problem is
4. Driver version for soundcard.

It's a recent trend to rely entirely on the Microsoft, while older soundcards always had at least an FM synthesis (Good old OPL3)
 
#3
I have Win XP SP2 but I don't have Microsoft GS software wavetable for some reason. I have the latest drivers for my sound. All I know about my sound is that it's an AC97 onboard sound for a gigabyte motherboard. I'm using directX 9c. Thanks so much for your quick reply
 
#4
Try http://www.lavalys.com/products/overview.php?pid=1&lang=en - Everest home for some more system info, though I'd guess on the chip being either Realtek or CMI.

In case something has corrupted Directx. maybe going over it with the offline reditributable installer may help

http://www.microsoft.com/downloads/...11-62fe-4f61-aba1-914185249413&displaylang=en

Find an alternate source for the file if you can't be bothered doing the "genuine" validation, though I spotted 3 different file sizes - WORRYING!
 
#5
Thanks for your help. I have the genuine Direct X so I don't think its that problem. I'll try the other thing you suggested and I'll post back with more info.

Thanks again
 
#7
hunnich said:
I downloaded Everest but I'm not sure what to do with it and what it does exactly.
run it and grab all informations about Multimedia, DirectX and your soundcard to post them here;


Greetings from
Duracell
 
#8
Windows Audio
Device Identifier Device Description
midi-out.0 0001 0066 Realtek AC97 Audio
mixer.0 0001 0068 Realtek AC97 Audio
wave-in.0 0001 0065 Realtek AC97 Audio
wave-out.0 0001 0064 Realtek AC97 Audio

PCI/PNP Audio
Device Description Type
SiS 7012 Audio Device PCI

Direct X - Primary Sound Sriver
Field Value
DirectSound Device Properties
Device Description Primary Sound Driver
Driver Module
Primary Buffers 1
Min / Max Secondary Buffers Sample Rate 8000 / 192000 Hz
Primary Buffers Sound Formats 8-bit, 16-bit, Mono, Stereo
Secondary Buffers Sound Formats 8-bit, 16-bit, Mono, Stereo
Total / Free Sound Buffers 26 / 25
Total / Free Static Sound Buffers 26 / 25
Total / Free Streaming Sound Buffers 26 / 25
Total / Free 3D Sound Buffers 26 / 25
Total / Free 3D Static Sound Buffers 26 / 25
Total / Free 3D Streaming Sound Buffers 26 / 25

DirectSound Device Features
Certified Driver Yes
Emulated Device No
Precise Sample Rate Supported
DirectSound3D Supported
Creative EAX 1.0 Supported
Creative EAX 2.0 Supported
Creative EAX 3.0 Not Supported

Direct X - Realtec AC97 Audio
Field Value
DirectSound Device Properties
Device Description Realtek AC97 Audio
Driver Module ALCXWDM.SYS
Primary Buffers 1
Min / Max Secondary Buffers Sample Rate 8000 / 192000 Hz
Primary Buffers Sound Formats 8-bit, 16-bit, Mono, Stereo
Secondary Buffers Sound Formats 8-bit, 16-bit, Mono, Stereo
Total / Free Sound Buffers 26 / 25
Total / Free Static Sound Buffers 26 / 25
Total / Free Streaming Sound Buffers 26 / 25
Total / Free 3D Sound Buffers 26 / 25
Total / Free 3D Static Sound Buffers 26 / 25
Total / Free 3D Streaming Sound Buffers 26 / 25

DirectSound Device Features
Certified Driver Yes
Emulated Device No
Precise Sample Rate Supported
DirectSound3D Supported
Creative EAX 1.0 Supported
Creative EAX 2.0 Supported
Creative EAX 3.0 Not Supported

Direct X Music - Realtek AC97 Audio
Field Value
DirectMusic Device Properties
Device Description Realtek AC97 Audio
Synthesizer Type Software
Device Class Output Port
Device Type WDM Multimedia
Audio Channels 2
MIDI Channels 16000
Voices 1000
Available Memory System Memory

DirectMusic Device Features
Built-In GM Instrument Set No
Built-In Roland GS Sound Set No
DirectSound Not Supported
DLS L1 Sample Collections Supported
DLS L2 Sample Collections Not Supported
External MIDI Port No
Fixed DLS Memory Size No
Port Sharing Not Supported
Chorus Effect Not Supported
Delay Effect Not Supported
Reverb Effect Supported



Guys this is all the information about sound and music. Please help me with this problem. Thank you.
 
#9
try uninstall reinstall the AC97 drivers making sure you have the correct drivers for your motherboard as not all AC97 drivers will work they should be on your mainboard cd rom that came with the board or on the software disk supplied with your machine :)


check also is in dxdiag check under music tab it should say that the microsoft midi mapper is [EMULATED] :)

run the tests for each device in the music tab under TEST DIRECT MUSIC and check each device by highlighting them in the box marked TEST USING THIS PORT and see if there is sound for each device :)

also its worth checking in audio properties (right click volume icon on task bar) and choose adjust audio properties then choose the audio tab and make sure you are using microsoft GS wavetable SW Synth as your midi device for midi playback :)


secondly click the VOLUME tab under that and check that the volume for the SW synth is not muted and is set to MAX :)

if the SW synth slider is not showing then click options at the top of the volume sliders panel and choose properties under the ajust volume for playback there are several checkboxes for playback devices make sure there is a tick in SW synth then it will appear in the volume control panel :)
 
#10
Thanks VIPER_1069,

but I don't have microsoft midi mapper at all. Also, I don't have microsoft GS wavetable SW Synth either. I'm not sure what is wrong. Where can I getr it from? I know its supposed to be with windows but I don't have it at all.

I've tried to reinstall the original drivers that came with the cd but there was no help. Then I updated the drivers on the official Realtek website as well, nut they don't work either. Please help me.
 
#11
hunnich said:
... but I don't have microsoft midi mapper at all. Also, I don't have microsoft GS wavetable SW Synth either.
Did you rip off Windows' Media Player? so the software synthesizer might be gone this way; :confused:
 
#12
What do you mean "rip off"? I downloaded it from Microsoft.

And also... suddenly there is a "Microsoft Synthesiser in my Direct Music section.

Microsoft Synthesizer
Field Value
DirectMusic Device Properties
Device Description Microsoft Synthesizer
Synthesizer Type Software
Device Class Output Port
Device Type User-Mode Synthesizer
Audio Channels 2
MIDI Channels 16000
Voices 1000
Available Memory System Memory

DirectMusic Device Features
Built-In GM Instrument Set No
Built-In Roland GS Sound Set No
DirectSound Supported
DLS L1 Sample Collections Supported
DLS L2 Sample Collections Supported
External MIDI Port No
Fixed DLS Memory Size No
Port Sharing Not Supported
Chorus Effect Not Supported
Delay Effect Not Supported
Reverb Effect Supported

I noticed these two in particular
"Built-In GM Instrument Set No
Built-In Roland GS Sound Set No"

In dxdiag there is this dialogue when I click on Microsoft Synthesiser.
"No General MIDI DLS file was specified in the registry."
 
Last edited:
#13
hunnich said:
What do you mean "rip off"? I downloaded it from Microsoft.
I DONT think DURACELL means for you to take his wording quite so LITERALLY i think he means did you remove it !?

it may of been when removed or upgraded and been corrupted during this process :(
 
#16
No worries Duracell, but no. It was upgraded from an original version with an original version from the microsoft website. Also I have tried reinstalling it but it doesn't help either. I noticed this In dxdiag there is this dialogue when I click on Microsoft Synthesiser.
"No General MIDI DLS file was specified in the registry."

I was wondering: If I can find a copy of this file how do I specify it in the registry?
 
#17
hunnich said:
I click on Microsoft Synthesiser.
"No General MIDI DLS file was specified in the registry."
I was wondering: If I can find a copy of this file how do I specify it in the registry?
the file is named "gm.dls" and is usually located in "C:\WINDOWS\system32\drivers\"

i will attach the file and the registry pointer (GM-DLS.reg);


anyway, it seems your Windows is corrupted; time to think about a fresh installation;
 

Attachments

#18
The usual windows advice...

Small problems - reboot, large problems - reinstall, really big problems - stick picture of Bill Gates on dartboard and switch to Linux, then stick picture of penguin on dartboard!

Seriously, when windows goes wrong, it often cannot be put right without reinstalling, while the old Win98 dodges (remove device in device manager, and allow it to redetect) are often less effective - kick it hard enough, and 98 would go the way you told it to, while XP tends to go it's own way regardless.
 
#19
Hey guys,
I'm now using SynthFont which loads a specific soundfont everytime I open it. It works pretty well but some drum sounds come out as clonks. I've downloaded many different (quite large) soundfonts but they still clonk. The ones I have are all about 80-140mbs (I'm not sure if size means anything though). Are there any really good soundfonts with heaps of drum kits in them that I can try?
 
Top