Dvd Rom Door Keeps Opening And Closing


New member
anyone know why. i checked for adware malware and trojans
nothing, even with antivirus.
it started over night. i got up this morning and the door was open. then it shut,then open. etc. :confused:
Conflicting software(packet writing software installed?) or failing hardware?
Try another drive perhaps to see if it does the same.
If it opens about 2 seconds after closing, that would suggest a sensing fault in the drive - the same way as most drives will retract the tray if blocked during opening, they will eject the tray again if the mechanism fails to detect that it is closed - had it happen to one, with a dirty optosensor.

If it closes, operates normally, then randomly ejects, that suggests a software problem, or a prank.
I had it once with a Toshiba DVD-ROM.
The most convenient solution was trashing it, but unfortunately I toyed a bit too much with system, settings, connections etc before deciding to do that.
If you have a spare psu take out the drive from your pc and connect the drive to the psu, if the drive is failing then it´s going to behave the same way with power only. Then youy could try cleaning the unit with a compressed air can, if you´re more in the DIY side then open the unit and clean all mechanical and optical sensors but the laser (do not touch the laser sensor).
Good idea, actually, just unplugging the ribbon cable would rule out anything other than an electromechanical issue with the drive, but the reaction to tray position sensing failure is usually immediate - I also had the opposite effect, where the tray would retract 2 seconds after ejecting, made swapping CDs a bit of a time-trial. These days, unless you enjoy tinkering, it's barely worth trying to repair a drive... I shudder at the price I paid for my first CD-ROM, Cd-writer, DVD-ROM, DVD writer - and I wasn't even an "early adopter".


New member
Mine just starting doing this, so I've tried many of the recommendations offered here and elsewhere. The one that's worked is simply shooting canned air into the spaces around the tray button, indicating that the switch sensor was just dirty. This has also cleared up the tray not opening problem that preceded this one.